eclipse で Visual Editor メモ

インストール

必要なもの

ここ からダウンロード。
(右のメニューから一通り辿れる。)

  • eclipse SDK(当然)
  • Visual Editor
    eclipse のバージョンに合うものでないと動かないので注意。
  • Eclipse Modeling Framework (EMF)
    これもバージョン注意。
  • Graphical Editing Framework (GEF)
    これもバージョン注意。

ダウンロードするものは、Runtime で良い。
※SDK を入れれば間違いないが、サイズが大きい。

プラグインのインストールは、アーカイブ(zip)を展開して出てくる "eclipse" というフォルダを、そのまま eclipse をインストールした フォルダ(同じ名前のフォルダがある)に上書きすれば良い。

バージョン違いだと動作しないが、基本的に全て最新バージョンを使えば合うはず。

				最新		日本語可能
	eclipse			3.2		3.1.2
	VE			1.2		1.1.0.1
	GEF			3.2		3.1
	EMF			2.2		2.1.0

で、動作確認。

ただし、最新バージョンには言語パッケージがない場合がある。

※現状の最新は eclipse 3.2 だが、この言語パッケージはまだない。
※VEを含む eclipse の All-In-One eclipse なるものもあるらしい。

参考URL


MLEXP. Wiki


トップ   編集 凍結解除 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2010-05-15 (土) 12:07:59 (3740d)