Domino といっても Lotus じゃないよ?MIDIシーケンサの Domino です。
インタフェイスは レコンポーザ → Cherry → Domino みたいな。

domino_main.png

Domino で VST

Domino 自身は VST に対応していないけど、別の VSTホストを踏み台にすれば VSTi を使うことができる。

  1. VST Host を入手。
    • VSTHost
      「current version here」というところからダウンロード。
  2. VST Host のzipをダウンロードしたら適当なところに展開。
    C:\VSTHost
  3. 仮想 MIDI ケーブル「MIDI Yoke」を入手。
    • MIDIOX
      左リンクメニュー「MIDI Yoke」から一番新しいのをダウンロード。(msiファイル)
  4. MIDI Yoke の msi を実行してインストール。
    • Windows Vista/7 の場合は管理者権限でインストールする必要があるかも。
  5. VSTi を入手。
    • ここは Synth1 という VSTiプラグインを使ってみる。
      Daichi LaboratoryDownload から、一番新しいのをダウンロード。
  6. Synth1 をダウンロードしたら、VSTi を入れるディレクトリをつくってそこに展開。
    今後もVSTiを使う場合は、決まったディレクトリに配備していく方が良い。
    ここは C:\VSTPlugins というディレクトリをつくってその中に展開。
    (C:\VSTPlugins\Synth1 となる)
  7. VST Host を起動する。
    vsth_001.png

  8. VST Host のメニュー「Device」→「Wave...」を選択。
    vsth_002.png

  9. 「Output Port」に有効なデバイスを選択。
    よくわからなければ「MME:サウンドマッパー」で。※ ASIOドライバがあればそれがベスト。
    vsth_003.png

  10. VST Host のメニュー「Device」→「MIDI...」を選択。
    vsth_004.png

  11. 「MIDI Input Devices」タブを開いて、「In From MIDI Yoke」を選択。
    いくつか表示されるけど、とりあえず「In From MIDI Yoke:1」だけ選択。
    vsth_005.png

  12. VST Host のメニュー「File」→「Set PlugIn? Path...」を選択。
    vsth_006.png

  13. 「VST PlugIn? Paths」に 上でつくった VSTi用ディレクトリを入力。
    → C:\VSTPlugins
    vsth_007.png

  14. VST Host のメニュー「File」→「Rescan PlugIns?」を実行。
    vsth_008.png

  15. VST Host ツールバーの「Load PlugIn?」を選択。(左から2番目のボタン)
    vsth_009.png

  16. 「Synth1」→「Synth1 Soft Synth」を選択。

    vsth_010.png

    コンソール上で「Engine Output」と「Synth1」が接続された図になる。
    vsth_011.png

  17. VST Host コンソール中の「Synth1」の「MIDI Parameters」ボタンを押す。
    vsth_012.png

  18. 「MIDI Input Devices」で「In From MIDI Yoke:1」を選択。
    vsth_013.png

  19. VST Host のメニュー「Window」→「Master」でボリューム表示をしておく。
    vsth_014.png

    vsth_015.png

  20. Domino を起動。
    dmn_001.png

  21. Domino のメニュー「ファイル」→「環境設定」を開く。
    dmn_002.png

  22. 「MIDI-OUT」の設定を開く。
    dmn_004.png

  23. いずれかのポートの「MIDI OUT デバイス」に「Out To MIDI Yoke:1」を選択。
    ここは「ポートB」を選択してみる。
    「音源(音源定義ファイル)」は何でも良い。とりあえず「GM Level1」とかで。
    dmn_005.png

  24. Domino のどれかトラックを右クリックして「トラックのプロパティ」を選択。
    dmn_006.png

  25. 「ポート」に、MIDI Yoke を選択したポート(ポートB)を選択。
    dmn_007.png

  26. 「ペン」ツールなどで、そのトラックのピアノロールでクリックしてみる。
    Synth1の音が出れば、VSTiでつながったということ。

Domino で SoundFont

SoundFont の解説は こちら で。
Domino自身はSoundFontは使えないけど、VSTi経由で使うことならできる。

  1. VSTi の設定を済ませる。(上記参照)
  2. sfz を入手。
    • Cakewalk - SFZ Player
      これは SoundFont を VSTi で使えるようにするアプリでありプラグイン。
      ダウンロード時にメールアドレスなどの入力を求められるけど、フリーソフト。
  3. ダウンロードしたら、VSTi用のディレクトリに展開。(VSTi設定の項を参照)
    → C:\VSTPlugins\sfz
  4. 適当な SoundFont をダウンロード。
  1. SoundFont をダウンロードしたら適当な場所に展開。
    これも SoundFont 用の決まったディレクトリをつくっておくと良い。
  2. VST Host を起動。
  3. VST Host のメニュー「File」→「Rescan PlugIns?」を実行。
  4. VST Host ツールバーの「Load PlugIn?」を選択。(左から2番目のボタン)
  5. 「sfz」→「sfz」を選択。
    コンソール上で「Engine Output」と「sfz」が接続された図になる。
  6. VST Host コンソール中の「sfz」の「MIDI Parameters」ボタンを押す。
  7. 「MIDI Input Devices」で「In From MIDI Yoke:1」を選択。
  8. VST Host コンソール中の「sfz」の「PlugIn? Edit」ボタンを押す。
    sfz_000.png

  9. sfz の設定画面が表示されるので、「FILE」に上記でダウンロードした SoundFont を選択する。
    sfz_001.png

  10. Domino 起動。
  11. Domino のメニュー「ファイル」→「環境設定」を開く。
  12. 「MIDI-OUT」の設定を開く。
  13. いずれかのポートの「MIDI OUT デバイス」に「Out To MIDI Yoke:1」を選択。
    ここは「ポートB」を選択してみる。
    「音源(音源定義ファイル)」は何でも良い。とりあえず「GM Level1」とかで。
  14. Domino のどれかトラックを右クリックして「トラックのプロパティ」を選択。
  15. 「ポート」に、MIDI Yoke を選択したポート(ポートB)を選択。
  16. 「ペン」ツールなどで、そのトラックのピアノロールでクリックしてみる。
    sfz(を通して SoundFont)の音が出ればOK。

Domino で複数の VSTi を使う。

ひとつのポートでも、フィルタをかければ複数のVSTiを演奏可能。
例えば、Synth1 を Ch1 に、sfz を Ch2 に出力するやり方を、以下に記述。

  1. VST Host 起動。
  2. VST Host コンソールで、「Synth1」と「sfz」(2つ)をロードする。
    ツールバー「Load PlugIn?」で。
    「Output Engine」の入力に、2つの VSTi の出力がつながったような図になる。
  3. コンソール中の「Synth1」の「MIDI Filters」ボタンを押す。
    ms_001.png

  4. 「MIDI Input Devices」タブで「In From MIDI Yoke:1」を選択。
  5. 「MIDI Input Devices」タブの右下の「Filter Settings...」ボタンを押す。
    ms_002.png

  6. 「Channels」の設定で、1以外のチェックボックスをONにする。
    これで Ch1 以外のチャンネルで Synth1 の出力が抑止される。
    ms_003.png

  7. コンソール中の「sfz」の「MIDI Filters」ボタンを押す。
  8. 「MIDI Input Devices」タブで「In From MIDI Yoke:1」を選択。
  9. 「MIDI Input Devices」タブの右下の「Filter Settings...」ボタンを押す。
  10. 「Channels」の設定で、2以外のチェックボックスをONにする。
    これで Ch2 以外のチャンネルで sfz の出力が抑止される。
    ms_004.png

  11. Domino 起動。
  12. Domino のメニュー「ファイル」→「環境設定」を開く。
  13. 「MIDI-OUT」の設定を開く。
  14. いずれかのポートの「MIDI OUT デバイス」に「Out To MIDI Yoke:1」を選択。
    ここは「ポートB」を選択。
  15. Domino のいずれかのトラック(「トラック1」とする)を右クリックして「トラックのプロパティ」を選択。
    1. 「ポート」に、MIDI Yoke を選択したポート(ポートB)を選択。
    2. 「チャンネル」に「1」を選択。
      ms_005.png

  16. Domino の上記とは異なるトラック(「トラック2」とする)を右クリックして「トラックのプロパティ」を選択。
    1. 「ポート」に、MIDI Yoke を選択したポート(ポートB)を選択。
    2. 「チャンネル」に「2」を選択。
      ms_006.png

  17. 「トラック1」のピアノロールを「ペン」ツールなどでクリックしてみる。
    Synth1 の音だけが出ればOK。
  18. 「トラック2」のピアノロールを「ペン」ツールなどでクリックしてみる。
    sfz の音だけが出ればOK。

参考サイト


MLEXP. Wiki | DTMメモ


添付ファイル: filesfz_000.png 1120件 [詳細] filesfz_001.png 1075件 [詳細] filems_005.png 1114件 [詳細] filems_006.png 1072件 [詳細] filems_004.png 1128件 [詳細] filems_003.png 1151件 [詳細] filems_002.png 1025件 [詳細] filems_001.png 1043件 [詳細] filevsth_012.png 1024件 [詳細] filevsth_015.png 992件 [詳細] filevsth_014.png 957件 [詳細] filevsth_013.png 1072件 [詳細] filevsth_011.png 1040件 [詳細] filevsth_010.png 1010件 [詳細] filevsth_009.png 1085件 [詳細] filevsth_008.png 1064件 [詳細] filevsth_007.png 1111件 [詳細] filevsth_006.png 1038件 [詳細] filevsth_005.png 1206件 [詳細] filevsth_004.png 1069件 [詳細] filevsth_003.png 1147件 [詳細] filevsth_002.png 1008件 [詳細] filevsth_001.png 1349件 [詳細] filedmn_007.png 1128件 [詳細] filedmn_006.png 1084件 [詳細] filedmn_005.png 1074件 [詳細] filedmn_004.png 1086件 [詳細] filedmn_003.png 593件 [詳細] filedmn_002.png 1118件 [詳細] filedmn_001.png 1089件 [詳細] filedm007.png 669件 [詳細] filedm006.png 667件 [詳細] filedm005.png 650件 [詳細] filedm004.png 687件 [詳細] filedm003.png 622件 [詳細] filedm002.png 734件 [詳細] filedm001.png 668件 [詳細] filedomino_main.png 1252件 [詳細]

トップ   編集 凍結解除 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2010-09-26 (日) 11:31:15 (2438d)